WordPress 4.9.5にあげたら「このページにアクセスする権限がありません」エラー

古めのWordpress(たしか4.6)を一気にWordpress 4.9.5をあげました
アップグレードはうまくいったようですが、管理画面へアクセスすると

このページにアクセスする権限がありません

となってしまいました

どれかのプラグインが対応してないのかと、プラグインを1つずつ外してみましたがうまくいきませんでした
(プラグインディレクトリをリネームしてみて)

いろいろ調べた結果、httpsで動かしているサイトだったので、
wp-config.php にhttpsを強制するコードを追記

define('FORCE_SSL_ADMIN', true);
if (strpos($_SERVER['HTTP_X_FORWARDED_PROTO'], 'https') !== false) {
    $_SERVER['HTTPS']='on';
}

これでうまくいきました

参考:
Administration Over SSL « WordPress Codex

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です