rbenvを使っているとcronでrubyのバージョンが古かった

rbenvでrubyをインストールした環境でcronを使ってrubyプログラムを動かしているつもりが動かなくなってました
gemがないとかでエラーが

手っ取り早くフルパスを指定してあげました

$ crontab -e

*/5 * * * * /usr/local/rbenv/versions/2.3.0/bin/ruby ./test.rb   

いけてないですが応急処置

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください