vagrantでVirtualboxとGuestAdditionsのバージョンを合わせたい

$ vagrant up
したらいつからかこんなメッセージが出てました

Got different reports about installed GuestAdditions version:
Virtualbox on your host claims:   4.1.12
VBoxService inside the vm claims: 4.3.30
Going on, assuming VBoxService is correct...
GuestAdditions seems to be installed (4.3.30) correctly, but not running.
Got different reports about installed GuestAdditions version:
Virtualbox on your host claims:   4.1.12
VBoxService inside the vm claims: 4.3.30
Going on, assuming VBoxService is correct...

Virtualboxをアップデートしてから、GuestAdditionとバージョンがあってないとか
GuestAdditionのバージョンをあげればよさそうでしたが

$ vagrant plugin list

vagrant-cachier (1.2.1)
vagrant-login (1.0.1, system)
vagrant-omnibus (1.4.1)
vagrant-share (1.1.4, system)
vagrant-vbguest (0.10.0)

dotless-de/vagrant-vbguest が入っててこれが自動でアップデートしてくれるはずだった気が..
これもアップデートされるかなと

$ vagrant plugin install vagrant-vbguest

で確認

$ vagrant plugin list

vagrant-vbguest (0.10.1)

バージョン上がった

$ vagrant reload

GuestAdditions 4.3.30 running --- OK.

したらエラーでなくなりました!
よかった、よかった

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください