unzipでneed PK compat. v4.5 (can do v2.1)のエラー

GUIでUbuntuをさわりたかったので
仮想ハードディスクイメージのダウンロード | Ubuntu Japanese Team
から仮想のイメージを落としてきて

$ unzip ubuntu-ja-14.04-desktop-amd64-vhd.zip

Archive:  ubuntu-ja-14.04-desktop-amd64-vhd.zip
   skipping: ubuntu-ja-14.04-desktop-amd64/ubuntu-ja-14.04-desktop-amd64.vhd  need PK compat. v4.5 (can do v2.1)

あれ、解凍できない
PKZIP formatとかいうのらしいので、対応しているので解凍

$ p7 e ubuntu-ja-14.04-desktop-amd64-vhd.zip

7-Zip [64] 9.20  Copyright (c) 1999-2010 Igor Pavlov  2010-11-18
p7zip Version 9.20 (locale=ja_JP.UTF-8,Utf16=on,HugeFiles=on,4 CPUs)

Processing archive: ubuntu-ja-14.04-desktop-amd64-vhd.zip

Extracting  ubuntu-ja-14.04-desktop-amd64/ubuntu-ja-14.04-desktop-amd64.vhd

Everything is Ok

これでできました
e は extract ですね

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください