bundler+rbenvを使っていてrubyのバージョンをあげてみた

rbenvでrubyのバージョン管理をしていてrubyのバージョンを上げてみました

いまのrubyのバージョンを確認

$ ruby -v
2.2.0

$ rbenv versions
system
2.1.2
* 2.2.0 (set by /vagrant/.ruby-version)

でも入ってるrubyのバージョンが見れます

2.2.2を入れたいのでrbenvであるか確認

$ rbenv install –list

でなければ、rbenvを最新に

$ cd ~/.rbenv
$ git pull origin master
$ cd ~/.rbenv/plugins/ruby-build
$ git pull origin master

確認

$ rbenv install –list

で、2.2.2が出てきたのでインストール

$ rbenv install 2.2.2

しばし待ちます

これだとまだ有効になってないので有効に

$ rbenv local 2.2.2

確認

$ rbenv versions
system
2.1.2
2.2.0
* 2.2.2 (set by /vagrant/wazukatea/.ruby-version)

$ ruby -v
ruby 2.2.2p95

できました
bundle installするとエラーがでました

The `bundle' command exists in these Ruby versions:
  2.1.2
  2.2.0

再度bundler入れてみて
$ gem install bundler

直りました

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください