Gemfileのバージョンの指定の仕方

RubyのGemfilesへのバージョンの書き方を忘れるのでメモ

バージョンを4.1.8に固定する

gem "rails", "4.1.8"

バージョンを4.1.8以上の最新にする
4.2とか入ります

gem "rails", ">=4.1.8"

バージョンを4.1.8以上、4.1.xの最新が入ります
4.2以上にはなりません

gem "rails", "~>4.1.8"

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください