composerでHybridAuthをいれてみた

HybridAuth, Open Source Social Sign On PHP Libraryをcomposerでいれてみました

環境は
Ubuntu 14.04
php 7.0

$ composer require hybridauth/hybridauth:~2.6.0

するとエラーが..

Problem 1
    - Installation request for hybridauth/hybridauth ~2.6.0 -> satisfiable by hybridauth/hybridauth[v2.6.0].
    - hybridauth/hybridauth v2.6.0 requires ext-curl * -> the requested PHP extension curl is missing from your system.

ext-curlがないらしい
必要なものをいれてみます

$ sudo apt-get update
$ sudo apt-get install php-curl

これで再度

$ composer require hybridauth/hybridauth:~2.6.0

でうまく入りました

投稿者:

bgbgbg

フリーのエンジニアです